Fix build issue in bluez5 bbappend file
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-connectivity / bluez5 / bluez5_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2 SRC_URI_append = " \
3     file://bluetooth.conf \
4     file://tmpdir.conf \
5     file://obex.service \
6     file://bluetooth.service \
7     file://0001-obex-report-notification-status-on-incoming-message.patch \
8 "
9
10 FILES_${PN} += "${systemd_user_unitdir}/obex.service.d/tmpdir.conf"
11
12 do_install_append() {
13     install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf
14
15     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
16         mkdir -p ${D}${systemd_user_unitdir}/obex.service.d
17
18         install -m 0644 ${WORKDIR}/obex.service ${D}${systemd_user_unitdir}
19         install -m 0644 ${WORKDIR}/tmpdir.conf ${D}${systemd_user_unitdir}/obex.service.d/tmpdir.conf
20         mkdir -p ${D}/etc/systemd/user
21         ln -sf ${systemd_user_unitdir}/obex.service ${D}/etc/systemd/user/dbus-org.bluez.obex.service
22         mkdir -p ${D}${systemd_system_unitdir}
23         install -m 0644 ${WORKDIR}/bluetooth.service ${D}${systemd_system_unitdir}
24     fi
25 }