agl-service-navigation: add RDEPENDS
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-apis / agl-service-navigation / agl-service-navigation_git.bb
1 SUMMARY     = "Navigation Service Binding"
2 DESCRIPTION = "AGL Navigation Service API Binding"
3 HOMEPAGE    = "https://github.com/AGLExport/agl-service-navigation"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = "json-c libdbus-c++"
10
11 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-navigation;protocol=https;branch=${AGL_BRANCH}"
12 SRCREV = "${AGL_APP_REVISION}"
13
14 PV = "0.1+git${SRCPV}"
15 S  = "${WORKDIR}/git"
16
17 inherit cmake aglwgt pkgconfig
18
19 RDEPENDS_${PN} += "json-c libdbus-c++"