Add gateway demo
[AGL/meta-agl-demo.git] / meta-agl-kvm-demo / recipes-platform / images / agl-kvm-demo-flutter-preconfigured.bb
1 require agl-kvm-demo.bb
2
3 SUMMARY = "AGL KVM preconfigured Flutter demo image"
4
5 # The databroker runs on the host to simplify things when running
6 # clients on the host instead of just in the guests.
7 IMAGE_FEATURES += " \
8     kuksa-val-databroker \
9     kuksa-val-databroker-client \
10 "
11
12 # Until virtio sound is workable with QEMU, run the audio using
13 # services on the host for a better demo experience.  At the
14 # moment, this also includes the HVAC service since it does not
15 # make sense to try to make things more fine-grained with respect
16 # to configuration for where things expect to find the databroker.
17 # It will need to be revisited when virtio-snd, virtio-gpio, etc.
18 # become feasible to use.
19 HOST_AUDIO_INSTALL = " \
20     packagegroup-agl-ivi-services-platform \
21     packagegroup-agl-ivi-multimedia-platform \
22     agl-service-radio-conf-kvm-demo \
23     packagegroup-pipewire \
24     wireplumber-config-agl \
25     wireplumber-policy-config-agl \
26     udisks2 \
27     ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "packagegroup-pipewire-tools mpc" , "", d)} \
28 "
29
30 IMAGE_INSTALL += "\
31     kuksa-databroker-agl-demo-cluster \
32     ${HOST_AUDIO_INSTALL} \
33 "
34
35 GUEST_VM1_IMAGE = "agl-ivi-demo-flutter-guest-preconfigured"
36 GUEST_VM2_IMAGE = "agl-cluster-demo-flutter-guest-preconfigured"