Rework KVM demo configuration
[AGL/meta-agl-demo.git] / meta-agl-kvm-demo / recipes-platform / images / agl-kvm-demo-flutter-preconfigured.bb
1 LICENSE = "MIT"
2
3 require agl-kvm-demo.bb
4
5 SUMMARY = "AGL KVM+QEMU preconfigured Flutter demo image"
6
7 # If building with "agl-kvm-host-kuksa", the databroker and likely
8 # some clients run on the host
9 IMAGE_FEATURES += " \
10     kuksa-val-databroker \
11     kuksa-val-databroker-client \
12 "
13
14 # Until virtio sound is workable with QEMU, run the audio using
15 # services on the host for a better demo experience.  At the
16 # moment, this also includes the HVAC service since it does not
17 # make sense to try to make things more fine-grained with respect
18 # to configuration for where things expect to find the databroker.
19 # It will need to be revisited when virtio-snd, virtio-gpio, etc.
20 # become feasible to use.
21 HOST_AUDIO_INSTALL = " \
22     packagegroup-agl-ivi-services-platform \
23     packagegroup-agl-ivi-multimedia-platform \
24     agl-service-radio-conf-kvm-demo \
25     packagegroup-pipewire \
26     wireplumber-config-agl \
27     wireplumber-policy-config-agl \
28     udisks2 \
29     ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "packagegroup-pipewire-tools mpc" , "", d)} \
30 "
31
32 IMAGE_INSTALL += "\
33     kuksa-databroker-agl-demo-cluster \
34     ${HOST_AUDIO_INSTALL} \
35 "
36
37 GUEST_VM1_IMAGE = "agl-ivi-demo-flutter-guest-preconfigured"
38 GUEST_VM2_IMAGE = "agl-cluster-demo-flutter-guest-preconfigured"