vhost-device-sound recipe
[AGL/meta-agl-devel.git] / meta-agl-jailhouse / recipes-extended / jailhouse / virtio-ivshmem-block.bb
1 SUMMARY = "virtio-ivshmem-block built out of the kernel tree"
2 DESCRIPTION = "virtio-ivshmem-block built out of the kernel tree."
3 HOMEPAGE = "https://kernel.org"
4
5 LICENSE = "GPL-2.0-only"
6
7 PR = "r1"
8
9 DEPENDS = " \
10     virtual/${MLPREFIX}libc \
11     ${MLPREFIX}elfutils \
12     ${MLPREFIX}binutils \
13     bison-native flex-native xz \
14 "
15
16 do_configure[depends] += "virtual/kernel:do_shared_workdir"
17
18 PROVIDES = "virtual/virtio-ivshmem-block"
19
20 inherit linux-kernel-base kernel-arch
21
22 #kernel 3.1+ supports WERROR to disable warnings as errors
23 export WERROR = "0"
24
25 do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
26
27 inherit kernelsrc
28
29
30 #PACKAGE_ARCH = "${MACHINE_ARCH}"
31
32 S = "${WORKDIR}"
33
34 RDEPENDS:${PN}-dev = ""
35
36 EXTRA_OEMAKE = " CC="${CC} ${CFLAGS} ${LDFLAGS}" CPP="${CPP}""
37
38 do_configure() {
39     echo "configure"
40 }
41
42 do_compile() {
43
44         oe_runmake CC="${CC} -I${STAGING_DIR_TARGET}/usr/include/ " LD="${LD}" AR="${AR}" \
45                 -C ${STAGING_KERNEL_DIR}/tools/virtio/ O=${S} virtio-ivshmem-block
46
47 }
48
49 do_install(){
50
51     install -d ${D}${bindir}/
52     install -m 0755  ${STAGING_KERNEL_DIR}/tools/virtio/virtio-ivshmem-block ${D}${bindir}
53
54 }