Add layer to support Jailhouse hypervisor
[AGL/meta-agl-devel.git] / meta-agl-jailhouse / dynamic-layers / raspberrypi / recipes-bsp / trusted-firmware-a / trusted-firmware-a_%.bbappend
1 COMPATIBLE_MACHINE = "raspberrypi4"
2 TFA_BUILD_TARGET = "bl31"
3 TFA_PLATFORM = "rpi4"
4
5 # Skip installing the binary into /lib/firmware. We only need it on the boot
6 # partition that is generated from the files in DEPLOYDIR
7 do_install[noexec] = "1"
8
9 FILES_${PN} = ""
10
11 do_deploy() {
12     if ${@"true" if d.getVar('TFA_DEBUG') == '1' else "false"}; then
13         BUILD_PLAT=${B}/${BUILD_DIR}/debug/
14     else
15         BUILD_PLAT=${B}/${BUILD_DIR}/release/
16     fi
17
18     install -d ${DEPLOYDIR}/bcm2835-bootfiles
19     cp ${BUILD_PLAT}/bl31.bin ${DEPLOYDIR}/bcm2835-bootfiles/bl31.bin
20 }
21