Fix agl IC demo is not show both screen
[AGL/meta-agl-devel.git] / meta-agl-ic-container / recipes-platform / images / agl-instrument-cluster-container-demo.bb
1 SUMMARY = "AGL Instrument Cluster Cotainer Integration demo image"
2 LICENSE = "MIT"
3
4 require lxc-host-image-minimal.bb
5 require recipes-platform/images/agl-lxc-multi-partition-image.inc
6
7 CONTAINER_IMAGES ?= "agl-container-cluster:guest-image-cluster-demo \
8                      agl-container-ivi:guest-image-ivi-demo \
9                     "
10
11 IMAGE_INSTALL += " \
12     kernel-modules \
13     alsa-utils \
14     packagegroup-pipewire \
15     pipewire-ic-ipc \
16     wireplumber-config-agl \
17 "
18
19 # packages required for network bridge settings via lxc-net
20 IMAGE_INSTALL += " \
21     container-manager \
22     cm-config-cluster-demo \
23     cm-config-agl-momi-ivi-demo \
24     lxc-networking \
25     iptables-modules \
26     dnsmasq \
27     systemd-netif-config \
28     kernel-module-xt-addrtype \
29     kernel-module-xt-multiport \
30 "
31
32 # network manager to use
33 VIRTUAL-RUNTIME_net_manager = "systemd"
34
35
36 # Under the this line, shall describe machine specific package.
37 IMAGE_INSTALL:append:rcar-gen3 = " kernel-module-gles gles-user-module-firmware"