Move out r-car specific description to dynamic-layer
[AGL/meta-agl-devel.git] / meta-agl-ic-container / recipes-platform / images / agl-cluster-demo-lxc-host.bb
1 SUMMARY = "LXC host demo image"
2 LICENSE = "MIT"
3
4 require lxc-host-image-minimal.bb
5 require recipes-platform/images/agl-lxc-install-single-image.inc
6 require recipes-platform/images/agl-lxc-autostart.inc
7
8 CONTAINER_IMAGES ?= "agl-container-cluster:guest-image-cluster-demo \
9                      agl-container-ivi:guest-image-ivi-demo \
10                     "
11
12 IMAGE_INSTALL += " \
13     kernel-modules \
14     alsa-utils \
15     packagegroup-pipewire \
16     pipewire-ic-ipc \
17     wireplumber-config-agl \
18 "
19
20 # packages required for network bridge settings via lxc-net
21 IMAGE_INSTALL += " \
22     lxc-networking \
23     iptables-modules \
24     dnsmasq \
25     systemd-netif-config \
26     kernel-module-xt-addrtype \
27     kernel-module-xt-multiport \
28 "
29
30 # network manager to use
31 VIRTUAL-RUNTIME_net_manager = "systemd"