agl-compositor_git: Add minor fix for DRM lease
[AGL/meta-agl-devel.git] / meta-agl-ic-container / recipes-graphics / wayland / weston-init-guest_0.1.bb
1 SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor in guest cotainer"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5 SRC_URI = "file://weston.env \
6            file://weston.service \
7           "
8
9 S = "${WORKDIR}"
10
11 inherit features_check systemd
12
13 do_install() {
14     install -Dm644 ${WORKDIR}/weston.env ${D}${sysconfdir}/default/weston
15
16     # Install Weston systemd service and accompanying udev rule
17     install -D -p -m0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
18     sed -i -e s:/etc:${sysconfdir}:g \
19         -e s:/usr/bin:${bindir}:g \
20         -e s:/var:${localstatedir}:g \
21         ${D}${systemd_unitdir}/system/weston.service
22 }
23
24 PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26 # rdepends on weston-init-guest which depends on wayland
27 REQUIRED_DISTRO_FEATURES = "wayland"
28
29 FILES:${PN} += " \
30     ${sysconfdir}/xdg/weston/weston.ini \
31     ${systemd_system_unitdir}/weston.service \
32     ${sysconfdir}/default/weston \
33     "
34 CONFFILES:${PN} += " \
35     ${sysconfdir}/xdg/weston/weston.ini \
36     ${sysconfdir}/default/weston \
37     "
38 SYSTEMD_PACKAGES = "${PN}"
39 SYSTEMD_SERVICE:${PN} = "weston.service"
40 SYSTEMD_AUTO_ENABLE = "enable"
41
42 RDEPENDS:${PN} = " \
43     weston \
44     weston-ini \
45     "
46 RCONFLICTS:${PN} = "weston-init"