agl-compositor_git: Add minor fix for DRM lease
[AGL/meta-agl-devel.git] / meta-agl-ic-container / recipes-graphics / wayland / wayland-ivi-extension_git.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "https://github.com/COVESA/wayland-ivi-extension"
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
6
7 DEPENDS = "weston virtual/libgles2 pixman wayland-native"
8
9 PV = "2.3.2+git${SRCPV}"
10
11 SRC_URI = " \
12     git://github.com/COVESA/${BPN}.git;protocol=https;branch=master \
13     file://0001-Update-libweston-to-version-13.patch \
14 "
15 SRCREV = "60d616ad3abd925956207b9b6ff981afa004e792"
16
17 S = "${WORKDIR}/git"
18
19 inherit cmake pkgconfig
20
21 EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
22 EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
23
24 FILES:${PN} += "${datadir}/wayland-protocols/stable/ivi-application/ivi-application.xml"
25 FILES:${PN} += "${libdir}/weston/*"
26 FILES:${PN}-dbg += "${libdir}/weston/.debug/*"
27
28 # Need these temporarily to prevent a non-fatal do_package_qa issue
29 INSANE_SKIP:${PN} += "dev-deps"
30 INSANE_SKIP:${PN}-dev += "dev-elf dev-so"