Update mominavi to fix style error
[AGL/meta-agl-devel.git] / meta-agl-ic-container / recipes-demo / momiscreen / momiscreen_git.bb
1 SUMMARY     = "Momiyama home screen example"
2 DESCRIPTION = "The momiscreen is a home screen example. \
3                The momiscreen is not require agl-appfw."
4 LICENSE = "GPL-3.0-only"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
6
7 DEPENDS = " \
8     qtbase \
9     qtquickcontrols2 \
10     qtgraphicaleffects \
11     qtsvg \
12     "
13
14 PV = "1.0.0"
15
16 SRC_URI = "git://git.automotivelinux.org/apps/momiscreen;protocol=https;branch=${AGL_BRANCH} \
17            file://momiscreen.service \
18            file://momiscreen \
19           "
20 SRCREV = "22b44f911bf6c53298055626cef671a24e9e9069"
21
22 S = "${WORKDIR}/git"
23
24 inherit qmake5 systemd
25
26 QT_INSTALL_PREFIX = "/usr"
27
28 do_install:append() {
29         install -d ${D}/${systemd_unitdir}/system
30         install -m 0644 ${WORKDIR}/momiscreen.service ${D}/${systemd_unitdir}/system
31
32         install -m 0755 -d ${D}${sysconfdir}/default/
33         install -m 0755 ${WORKDIR}/momiscreen ${D}${sysconfdir}/default/
34 }
35
36 FILES:${PN} += " \
37     ${systemd_unitdir} \
38     ${sysconfdir}/*/* \
39     "
40 SYSTEMD_PACKAGES = "${PN}"
41 SYSTEMD_SERVICE:${PN} = "momiscreen.service"
42
43 RDEPENDS:${PN} = "qtsvg qtsvg-plugins qtsvg-qmlplugins"