Reworking environment variable setting for guest
[AGL/meta-agl-devel.git] / meta-agl-ic-container / recipes-demo / cluster-refgui / cluster-refgui_git.bb
1 DESCRIPTION = "AGL Cluster Reference GUI"
2 LICENSE = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://LICENSE;md5=5335066555b14d832335aa4660d6c376"
4
5 DEPENDS = " \
6     qttools-native \
7     qtmultimedia \
8 "
9
10 BRANCH = "master"
11 SRC_URI = "git://git.automotivelinux.org/src/cluster-refgui;protocol=https;branch=${BRANCH} \
12            file://cluster.service \
13            file://cluster \
14 "
15 SRCREV = "a16c6201be94a57eb8151a91699084d99694877c"
16
17 S = "${WORKDIR}/git"
18
19 inherit cmake cmake_qt5 systemd
20
21 # NOTE:
22 # The app currently assumes the mp4 video file is in the same
23 # directory, so changing this to ${bindir} to better match FHS
24 # requires code changes.
25 APP_DIR = "/opt/apps"
26 EXTRA_OECMAKE = "-DAPPS_INST_DIR=${APP_DIR}"
27
28 SYSTEMD_SERVICE:${PN} = "cluster.service"
29
30 do_install:append() {
31     install -d ${D}${systemd_unitdir}/system
32     install -m 0644 ${WORKDIR}/cluster.service ${D}${systemd_unitdir}/system/
33     
34     install -m 0755 -d ${D}${sysconfdir}/default/
35     install -m 0755 ${WORKDIR}/cluster ${D}${sysconfdir}/default/
36 }
37
38 FILES:${PN} += "${APP_DIR}/"
39
40 RDEPENDS:${PN} = " \
41     qtbase \
42     qtdeclarative \
43     qt3d \
44     qtgraphicaleffects \
45     qtmultimedia \
46     qtquickcontrols \
47     qtquickcontrols2 \
48     qtwayland \
49 "