Fix missing gles-user-module-firmware in agl-cluster-demo-lxc-host image
[AGL/meta-agl-devel.git] / meta-agl-ic-container / classes / guest-kernel-module.bbclass
1 DEPENDS:remove:aglcontainerguest = "${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-dummy", "linux-renesas", "", d)}"
2
3 do_configure[depends] = "${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-dummy", "", "make-mod-scripts:do_compile", d)}"
4
5 python __anonymous () {
6     # Need to use inline python here as, contrary to the BitBake docs,
7     # having noexec set at all disables the task, so using
8     # oe.utils.conditional to set it to "0" still ends up with the task
9     # disabled.
10     if d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-dummy":
11         d.setVarFlag("do_compile", "noexec", "1")
12 }
13
14 do_install:aglcontainerguest() {
15     # Create destination directory
16     install -d ${D}/${includedir}/
17 }
18
19 # Guest doesn't build the module, so go ahead and quiet warnings about
20 # double '/' in base recipe definition
21 FILES:${PN}:aglcontainerguest = ""