Enable cve-check in CI jobs for additional cve log files
[AGL/meta-agl.git] / meta-agl-flutter / recipes-platform / images / agl-image-flutter-debug.bb
1 require recipes-platform/images/agl-image-compositor.bb
2
3 SUMMARY = "Example Flutter application debug image for development"
4 LICENSE = "MIT"
5
6 CLANGSDK = "1"
7
8 # NOTES:
9 # - the package-management IMAGE_FEATURE and packagegroup-agl-core-devel
10 #   are explicitly added here to cover the usecase of building without
11 #   passing agl-devel to aglsetup.sh.  This is explicitly a debug image
12 #   where those are are always desired.
13 # - Getting the debug version of the application requires changing
14 #   the value of FLUTTER_APP_RUNTIME_MODES to include "debug",
15 #   which is outside the scope of this image recipe.
16
17 IMAGE_FEATURES += "ssh-server-openssh package-management dbg-pkgs"
18
19 IMAGE_INSTALL += "\
20     packagegroup-agl-core-devel \
21     \
22     weston-ini-conf-landscape \
23     \
24     flutter-auto-verbose-logs \
25     \
26     flutter-engine-sdk-dev \
27     \
28     flutter-gallery \
29 "