Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl.git] / meta-agl-core / recipes-platform / packagegroups / packagegroup-agl-graphical-compositor.bb
1 DESCRIPTION = "The minimal set of packages required for the AGL compositor"
2 LICENSE = "MIT"
3
4 inherit packagegroup features_check
5
6 # agl-compositor-init requires pam enabled if started via systemd
7 REQUIRED_DISTRO_FEATURES = "wayland ${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', 'pam', '', d)}"
8
9 RDEPENDS:${PN} += " \
10     agl-compositor \
11     agl-compositor-init \
12     ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
13 "