fe0b61f85dce1b6708cbc0836c19e088ffb61a53
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-shell-activator_git.bb
1 SUMMARY = " Application that switches/activates other application's windows "
2 DESCRIPTION = " A wayland client and a script that talks with the agl-compositor \
3 an tells it to display a specific application. Relies on the appid being \
4 started (already) by afm-util or the client shell (homescreen/WAM)"
5
6 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-shell-activator"
7 SECTION = "x11"
8 LICENSE = "MIT"
9 LIC_FILES_CHKSUM = "file://COPYING;md5=e978448a0d41d826d73890d9c22caf75"
10
11 DEPENDS = "wayland wayland-protocols wayland-native agl-compositor"
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-shell-activator.git;protocol=https;branch=${AGL_BRANCH}"
14 SRCREV = "5bdedb16112fa0faaf16f64ef440f451e9f787e4"
15
16 PV = "0.0.10+git${SRCPV}"
17 S = "${WORKDIR}/git"
18
19 inherit meson pkgconfig python3native
20
21 FILES_${PN} = " ${bindir}/agl-shell-activator \
22                 ${bindir}/agl-activator "