Convert to new override syntax
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor_git.bb
1 SUMMARY = "Reference Wayland compositor for AGL"
2 DESCRIPTION = "The AGL compositor is a reference Wayland server for Automotive \
3 Grade Linux, using libweston as a base to provide a graphical environment for \
4 the automotive environment."
5
6 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-compositor"
7 SECTION = "x11"
8 LICENSE = "MIT"
9 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
10
11 DEPENDS = "wayland wayland-protocols wayland-native weston \
12            ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
13
14 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
15 SRCREV = "59b6881bc315388ba0c8f1be382dce1f6aed3304"
16
17 PV = "0.0.10+git${SRCPV}"
18 S = "${WORKDIR}/git"
19
20 PACKAGECONFIG ?= ""
21 PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
22 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
23
24 inherit meson pkgconfig python3native
25
26 FILES:${PN} = " \
27                ${bindir}/agl-compositor \
28                ${bindir}/agl-screenshooter \
29                ${datadir}/${PN}/protocols/agl-shell.xml \
30                ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
31                ${libdir}/agl-compositor/libexec_compositor.so.0 \
32                ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
33               "
34
35 RDEPENDS:${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
36
37 FILES:${PN}-dev += " \
38         ${libdir}/agl-compositor/libexec_compositor.so \
39 "