Convert to new override syntax
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / rba / librba_1.0.bb
1 SUMMARY = "RBA"
2 DESCRIPTION = "Rule Based Arbitrator decides which of the content to display \
3 when a large number of contents to be displayed on the cockpit display device \
4 (CID, meter, HUD, etc.) occur simultaneously under a certain rule (arbitration)"
5
6 SECTION = "libs"
7 LICENSE = "Apache-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE;md5=13afa517927767fe9b7a65818a02bd8f"
9
10 INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
11
12 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/rba;protocol=https;branch=master"
13 SRCREV = "87c0278dfbcf0953330330c28a8d48636dd4df7e"
14
15 S = "${WORKDIR}/git"
16
17 inherit pkgconfig cmake
18
19 FILES:${PN} = "${libdir}/"
20 FILES:${PN}-dev = "${libdir}/pkgconfig/librba.pc \
21                    ${includedir}/ \
22                   "
23 INSANE_SKIP:${PN} += "dev-so"
24 INSANE_SKIP:${PN}-dev += "dev-elf"