meta-agl-core: systemd: Disable `BitRate` setting for `can*` network for VIRTIO.
[AGL/meta-agl.git] / meta-agl-core / recipes-core / systemd / systemd-conf-canbus_1.0.bb
1 SUMMARY = "Systemd canbus configuration"
2 DESCRIPTION = "Systemd may require slightly different configuration for \
3 different machines. This injects configuration for the CAN bus."
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7 PE = "1"
8
9 SRC_URI = "\
10     file://canbus-can.network \
11     file://canbus-virtio.network \
12 "
13
14 CANBUS_NETWORK_CONFIG ??= "canbus-can.network"
15 CANBUS_NETWORK_CONFIG:virtio-all ?= "canbus-virtio.network"
16
17 do_install() {
18     # Install canbus network script
19     install -d ${D}${nonarch_base_libdir}/systemd/network/
20     install -m 0644 ${WORKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
21 }
22
23 PACKAGE_ARCH = "${MACHINE_ARCH}"
24
25 FILES:${PN} = " \
26     ${nonarch_base_libdir}/systemd/network/*.network \
27 "