Re-enable PRserv and HASHserv after api migration
[AGL/meta-agl.git] / meta-agl-core / recipes-connectivity / connman-ncurses / connman-ncurses_git.bb
1 SUMMARY = "A simple ncurses interface for connman"
2 DESCRIPTION = "A simple ncurses interface for connman"
3 HOMEPAGE = "https://gitlab.com/iotbzh/connman-json-client"
4
5 SECTION = "console/network"
6
7 DEPENDS = "dbus ncurses connman json-c"
8
9 LICENSE = "GPL-2.0-only"
10 LIC_FILES_CHKSUM = "file://LICENSE;md5=8c16666ae6c159876a0ba63099614381"
11
12 SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https;branch=master \
13            file://stdbool-fixes.patch \
14            file://0001-Do-not-overwrite-CFLAGS.patch \
15            file://0001-Initialize-variables.patch \
16            "
17 SRCREV = "2b0f93ec9518c978c04807fe52e95315d6d80e6b"
18
19 inherit autotools pkgconfig
20
21 EXTRA_AUTORECONF += " -vfi"
22
23 S = "${WORKDIR}/git"
24
25 do_install () {
26     install -dm755 ${D}${bindir}
27     install -Dm755 connman_ncurses ${D}${bindir}
28 }
29
30 FILES:${PN} = "${bindir}/connman_ncurses"