SPEC-3723: restructure meta-agl
[AGL/meta-agl.git] / meta-agl-core / recipes-connectivity / connman-ncurses / connman-ncurses_git.bb
1 SUMMARY = "A simple ncurses interface for connman"
2 DESCRIPTION = "A simple ncurses interface for connman"
3 HOMEPAGE = "https://gitlab.com/iotbzh/connman-json-client"
4
5 SECTION = "console/network"
6
7 DEPENDS = "dbus ncurses connman json-c"
8
9 LICENSE = "GPLv2"
10 LIC_FILES_CHKSUM = "file://LICENSE;md5=8c16666ae6c159876a0ba63099614381"
11
12 SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https"
13 SRCREV = "2b0f93ec9518c978c04807fe52e95315d6d80e6b"
14
15 inherit autotools pkgconfig
16
17 EXTRA_AUTORECONF += " -i"
18 EXTRA_OECONF += " --disable-optimization --enable-debug"
19
20 S = "${WORKDIR}/git"
21
22 do_install () {
23     install -dm755 ${D}${bindir}
24     install -Dm755 connman_ncurses ${D}${bindir}
25 }
26
27 FILES_${PN} = "${bindir}/connman_ncurses"