Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl.git] / meta-agl-core / recipes-config / agl-users / agl-users_1.0.bb
1 SUMMARY = "AGL Users"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5 inherit allarch useradd
6
7 USERADD_PACKAGES = "${PN}"
8 USERADDEXTENSION = "useradd-staticids"
9
10 GROUPADD_PARAM:${PN} = "\
11     --system video ; \
12     --system pipewire ; \
13     -g 1001 agl-driver ; \
14 "
15
16 USERADD_PARAM:${PN} = "\
17     -g 1001 -u 1001 -G video,pipewire -o -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
18 "
19
20 ALLOW_EMPTY:${PN} = "1"