Add SELinux feature
[AGL/meta-agl.git] / meta-agl-core / dynamic-layers / meta-selinux / recipes-core / systemd / systemd-selinux-relabel_1.0.bb
1 SUMMARY     = "System unit to relabel systemd generated files"
2 LICENSE     = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 SRC_URI = "file://systemd-selinux-relabel.service \
6            file://systemd-selinux-relabel.sh \
7 "
8
9 inherit systemd allarch features_check
10
11 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
12
13 REQUIRED_DISTRO_FEATURES = "systemd"
14
15 do_configure[noexec] = "1"
16 do_compile[noexec] = "1"
17
18 do_install() {
19     install -d ${D}${systemd_system_unitdir}
20     install -m 0644 ${WORKDIR}/systemd-selinux-relabel.service ${D}${systemd_system_unitdir}/
21     install -d ${D}${sbindir}
22     install -m 0755 ${WORKDIR}/systemd-selinux-relabel.sh ${D}${sbindir}/
23 }
24
25 FILES:${PN} += "${systemd_system_unitdir}"