Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl.git] / meta-agl-core / classes / agl-core-image.bbclass
1 # AGL base image class
2 #
3 # As opposed to using core-image directly, this class:
4 # - does not pull in packagegroup-base-extended by default to minimize images.
5 #   This does mean that many of the oe-core / poky MACHINE and DISTRO features
6 #   (e.g. 3g, nfs, etc.) will not result in packages being automatically pulled
7 #   into images since that is driven via packagegroup-base.
8 # - includes hooks for integrating SELinux via meta-selinux
9 # - disables locale installation by default
10 #
11
12 # Disable locales
13 IMAGE_LINGUAS = ""
14
15 # Hook to allow inheriting e.g. selinux-image by default.
16 # Any bbclass used as a value should ultimately inherit core-image
17 AGL_BASE_IMAGE ?= "core-image"
18
19 inherit ${AGL_BASE_IMAGE}
20
21 FEATURE_PACKAGES_selinux = " \
22     packagegroup-agl-core-selinux \
23     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-core-selinux-devel', '', d)} \
24 "
25
26 IMAGE_FEATURES:append = " ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
27
28 CORE_IMAGE_BASE_INSTALL = " \
29     packagegroup-agl-core-boot \
30     \
31     ${CORE_IMAGE_EXTRA_INSTALL} \
32 "