Convert to new override syntax
[AGL/meta-agl.git] / meta-agl-bsp / virtualization-layer / recipes-extended / xen / xen_git.bbappend
1 FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2
3 # make the package machine-specific
4 PACKAGE_ARCH = "${MACHINE_ARCH}"
5
6 # rpi4 specifics
7 LIC_FILES_CHKSUM:raspberrypi4 = "file://COPYING;md5=4295d895d4b5ce9d070263d52f030e49"
8 XEN_REL:raspberrypi4 = "4.13"
9
10 SRCREV:raspberrypi4 = "721f2c323ca55c77857c93e7275b4a93a0e15e1f"
11 SRC_URI:append:raspberrypi4 = " file://0001-XEN-on-RPi4-1GB-lmitation-workaround-XEN-tries-to-al.patch"
12
13 #due to incorrect xen binary preparation in external library, we add additional deploy
14 do_deploy:append:raspberrypi4() {
15     if [ -f ${B}/xen/xen ]; then
16         install -m 0644 ${B}/xen/xen ${DEPLOYDIR}/xen-${MACHINE}
17     fi
18 }