4628f96f8bbe6578ad050ee3dae7b4dc8ee136f7
[AGL/meta-agl.git] / meta-agl-bsp / recipes-graphics / wayland / weston-ini-conf.bb
1 SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 SRC_URI = "file://core.cfg \
6            file://ivishell.cfg \
7            file://id-agent.cfg \
8            file://shell.cfg \
9            file://hdmi-a-1-270.cfg \
10           "
11
12 S = "${WORKDIR}"
13
14 PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16 do_compile() {
17     # Put all of our cfg files together.
18     rm -f ${WORKDIR}/weston.ini
19     for F in ${WORKDIR}/*.cfg; do
20         cat $F >> ${WORKDIR}/weston.ini
21         echo >> ${WORKDIR}/weston.ini
22     done
23     sed -i -e '$ d' ${WORKDIR}/weston.ini
24 }
25
26 do_install_append() {
27     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
28     install -d ${D}${WESTON_INI_CONFIG}
29     install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
30 }