14fbd02738386d71068b4c5ce58f763d506dee3d
[AGL/meta-agl.git] / meta-agl-bsp / recipes-graphics / wayland / weston-ini-conf.bb
1 SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 SRC_URI = "file://core.cfg \
6            file://shell.cfg \
7            file://hdmi-a-1-270.cfg \
8           "
9
10 S = "${WORKDIR}"
11
12 PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14 do_compile() {
15     # Put all of our cfg files together.
16     rm -f ${WORKDIR}/weston.ini
17     for F in ${WORKDIR}/*.cfg; do
18         cat $F >> ${WORKDIR}/weston.ini
19         echo >> ${WORKDIR}/weston.ini
20     done
21     sed -i -e '$ d' ${WORKDIR}/weston.ini
22 }
23
24 do_install_append() {
25     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
26     install -d ${D}${WESTON_INI_CONFIG}
27     install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
28 }