dfa0631a03fbb16088dc5056b8e45e425bb69f78
[AGL/meta-agl.git] / meta-agl-bsp / recipes-bsp / u-boot / u-boot-ota_2015.07.bb
1 include recipes-bsp/u-boot/u-boot.inc
2 DEPENDS += "dtc-native"
3
4 LICENSE = "GPLv2+"
5 LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
6
7 # This revision corresponds to the tag "v2015.07"
8 # We use the revision in order to avoid having to fetch it from the
9 # repo during parse
10 SRCREV = "baba2f57e8f4ed3fa67fe213d22da0de5e00f204"
11
12 SRC_URI += "file://0001-Set-up-environment-for-OSTree-integration.patch \
13             file://0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch \
14             file://0001-fixup-build-with-gcc6.patch \
15            "
16
17 PV = "v2015.07+git${SRCPV}"
18
19 EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline "
20 EXTRA_OEMAKE_append_qemux86 = " BUILD_ROM=y"
21 EXTRA_OEMAKE_append_qemux86-64 = " BUILD_ROM=y"
22
23 UBOOT_SUFFIX = "bin"
24 UBOOT_SUFFIX_qemux86 = "rom"
25 UBOOT_SUFFIX_qemux86-64 = "rom"