21142df5926a7f9d5eb68b08268461e6f1b59f37
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-graphics / libgles / ti-sgx-ddk-um_%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2 FILES_${PN} += "/etc/ti-sgx/"
3
4 SRC_URI_append = "\
5     file://pvr.service \
6 "
7
8 inherit systemd
9
10 SYSTEMD_PACKAGES = "${PN}"
11 SYSTEMD_SERVICE_${PN} = "pvr.service"
12
13 do_install_append() {
14         install -d ${D}${systemd_system_unitdir}
15         install -m 0755 ${WORKDIR}/pvr.service ${D}${systemd_system_unitdir}
16         install -d ${D}/etc/ti-sgx
17         install -m 0755 ${D}/etc/init.d/rc.pvr ${D}/etc/ti-sgx
18 }