3c35ad821ea2477deb65f9629aef76b198cd377c
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-arago / weston / weston_1.9.0.bbappend
1 #inherit append-code-change
2 # When configured for fbdev compositor, make it the default
3 PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor WESTON_NATIVE_BACKEND="fbdev-backend.so",--disable-fbdev-compositor,udev mtdev"
4 PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev libgbm mtdev"
5
6 PR_append = ".agl_arago_16"
7
8 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
9
10 RDEPENDS_${PN} += "weston-conf"
11
12 SRC_URI += " \
13         file://0001-weston1.9.0-Enabling-DRM-backend-with-multiple-displ.patch \
14         file://0002-Weston1.9.0-Allow-visual_id-to-be-0.patch \
15         file://0003-Weston1.9.0-Fix-virtual-keyboard-display-issue-for-Q.patch \
16         file://0004-Weston1.9.0-Fix-touch-screen-crash-issue.patch \
17         file://0001-udev-seat-restrict-udev-enumeration-to-card0.patch \
18         file://0001-Add-soc-performance-monitor-utilites.patch \
19 "
20
21 RDEPENDS_${PN}_remove = "weston-conf"
22
23 SRC_URI += " \
24       file://0001-ivi-shell-fix-TODO-which-expects-only-one-screen-in-.patch \
25       file://0002-ivi-shell-multi-screen-support-to-calcuration-of-a-m.patch \
26       file://0003-ivi-shell-avoid-update_prop-on-invisible-surfaces.patch    \
27       file://0004-ivi-shell-fix-layout_layer.view_list-is-not-initiliz.patch \
28       file://0005-ivi-shell-convert-from-screen-to-global-coordinates.patch  \
29       file://0006-ivi-shell-remove-a-code-which-expects-only-a-screen-.patch \
30       file://0007-ivi-shell-layout-Export-surface-destroy-callback.patch     \
31       file://0008-ivi-shell-Add-simple-IVI-shell-layout-controller.patch     \
32       file://0001-ivi-shell-Add-autolaunch-and-launch-rules-functional.patch \
33       file://0001-ivi-shell-layer-controller-ti-Improve-functionality.patch  \
34       file://0001-ivi-shell-Add-screenshooter-option.patch                   \
35       "