dra7xx-evm: platform specific additions for gst-bad
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-arago / gstreamer / gstreamer1.0-plugins-bad_1.6.3.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 PACKAGECONFIG = "faad"
4
5 # gstreamer is now also included on Keystone, be mindful of any Graphics dependencies
6 PACKAGECONFIG_append_omap-a15 = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
7 PACKAGECONFIG_append_ti43x = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
8 PACKAGECONFIG_append_ti33x = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
9
10 DEPENDS_append_omap-a15 = " \
11     libdce \
12     libdrm \
13 "
14
15 DEPENDS_append_ti43x = " \
16     libdrm \
17 "
18
19 DEPENDS_append_ti33x = " \
20     libdrm \
21 "
22
23 SRC_URI_append_ti43x = " \
24 "
25
26 SRC_URI_append_ti33x = " \
27 "
28
29 PACKAGE_ARCH = "${MACHINE_ARCH}"
30
31 BRANCH ?= "master"
32
33 SRC_URI = "git://git.ti.com/glsdk/gstreamer1-0-plugins-bad.git;protocol=git;branch=${BRANCH} \
34           "
35
36 S = "${WORKDIR}/git"
37
38 SRCREV_omap-a15 = "f0694b5fcec997036ef7df4d382b28e833c8ebfd"
39 SRCREV = "d0160ca810be30bf2b2e7681f5047933402efb52"
40
41 PR = "r21"