Upgrade to pyro
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-arago / gstreamer / gstreamer1.0-plugins-bad_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 PACKAGECONFIG = "faad"
4
5 # gstreamer is now also included on Keystone, be mindful of any Graphics dependencies
6 PACKAGECONFIG_append_omap-a15 = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
7 PACKAGECONFIG_append_ti43x = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
8 PACKAGECONFIG_append_ti33x = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
9
10 DEPENDS_append_omap-a15 = " \
11     libdrm \
12 "
13
14 DEPENDS_append_ti43x = " \
15     libdrm \
16 "
17
18 DEPENDS_append_ti33x = " \
19     libdrm \
20 "
21
22 ############## F I X M E #####################
23 # FIXME pyro
24 SRC_URI_append = " \
25     file://0001-gstdrmallocator-Add-DRM-allocator-support.patch \
26 "
27 DISABLED_SRC_URI_append_ti43x = " \
28     file://0002-parsers-Pick-previos-bug-fixes-on-different-parsers.patch \
29     file://0003-gstkmssink-Add-support-for-KMS-based-sink.patch \
30     file://0004-gstwaylandsink-Add-DRM-support-on-waylandsink.patch \
31     file://0002-kmssink-remove-DCE-dependencies.patch \
32     file://0003-kmssink-add-YUYV-support.patch \
33     file://0001-gstwaylandsink-add-input-format-I420-support.patch \
34 "
35
36 # FIXME pyro
37 DISABLED_SRC_URI_append_ti33x = " \
38     file://0001-gstwaylandsink-Add-mouse-drag-and-drop-support.patch \
39 "
40
41 # FIXME pyro
42 DISABLED_SRC_URI_append_omap-a15 = " \
43     file://0001-gstdrmallocator-Add-DRM-allocator-support.patch \
44     file://0002-parsers-Pick-previos-bug-fixes-on-different-parsers.patch \
45     file://0003-gstkmssink-Add-support-for-KMS-based-sink.patch \
46     file://0004-gstwaylandsink-Add-DRM-support-on-waylandsink.patch \
47     file://0002-kmssink-remove-DCE-dependencies.patch \
48     file://0003-kmssink-add-YUYV-support.patch \
49     file://0001-gstwaylandsink-add-input-format-I420-support.patch \
50     file://0005-gstwaylandsink-Implement-callbacks-for-version-5-of-.patch \
51 "
52 ################ F I X M E ####################
53
54 PACKAGE_ARCH = "${MACHINE_ARCH}"
55
56 PR = "r4"