8d3e6c7a738bbcb13697b29fa0b998e2083b3236
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-arago / gstreamer / gstreamer1.0-plugins-bad_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 PACKAGECONFIG = "faad"
4
5 # gstreamer is now also included on Keystone, be mindful of any Graphics dependencies
6 PACKAGECONFIG_append_omap-a15 = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
7 PACKAGECONFIG_append_ti43x = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
8 PACKAGECONFIG_append_ti33x = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
9
10 DEPENDS_append_omap-a15 = " \
11     libdrm \
12 "
13
14 DEPENDS_append_ti43x = " \
15     libdrm \
16 "
17
18 DEPENDS_append_ti33x = " \
19     libdrm \
20 "
21
22 ############## F I X M E #####################
23 # FIXME rocko
24 DISABLED_ROCKO_SRC_URI_append = " \
25     file://0001-gstdrmallocator-Add-DRM-allocator-support.patch \
26 "
27 ################ F I X M E ####################
28
29 PACKAGE_ARCH = "${MACHINE_ARCH}"
30
31 PR = "r4"