baf699a5f99f0347c29854022853f963f5eaacc5
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-support / imagemagick / imagemagick_6.9.2.bb
1 SUMMARY = "ImageMagick is an image convertion tools"
2 SECTION = "console/utils"
3 LICENSE = "ImageMagick"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=0887b670be7ef0c3cb37092b64d57514"
5 # FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
6 DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib fftw freetype"
7
8 # Important note: tarballs for all patchsets within a version are deleted when
9 # a new pachset is created. To avoid multiple patches for each patchset, try to
10 # update to the last pachset of a version
11 PATCHSET = "0"
12 SRC_URI = "http://www.imagemagick.org/download/releases/ImageMagick-${PV}-${PATCHSET}.tar.xz \
13 "
14 SRC_URI[md5sum] = "99471c8c3f38c9264faf5c4ca7a31287"
15 SRC_URI[sha256sum] = "07a2de28f7f9ab888ef47c02eb7e10cc3e0dd0e9797c5d71d6e71d19f842399e"
16
17 S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}"
18
19 inherit autotools pkgconfig update-alternatives
20
21 # xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
22 # if someone needs xml support then fix it first
23 EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-perl --disable-openmp --without-xml --disable-opencl"
24
25 CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
26 PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
27 PACKAGECONFIG[graphviz] = "--with-gvc,--without-gvc,graphviz"
28 PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
29 PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
30 PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg"
31 PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
32 PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
33 PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
34 PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt"
35
36 FILES_${PN} += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.so \
37                 ${libdir}/ImageMagick-${PV}/modules-Q16/*/*.la \
38                 ${libdir}/ImageMagick-${PV}/modules-Q16/filters \
39                 ${libdir}/ImageMagick-${PV}/modules-Q16/coders \
40                 ${libdir}/ImageMagick-${PV}/config-Q16 \
41                 ${datadir}/ImageMagick-6 "
42
43 FILES_${PN}-dev += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.a"
44
45 FILES_${PN}-dbg += "${libdir}/ImageMagick-${PV}/modules-Q16/*/.debug/*"
46
47 BBCLASSEXTEND = "native"
48
49 ALTERNATIVE_PRIORITY = "100"
50
51 ALTERNATIVE_${PN} = "animate compare composite conjure convert display \
52     identify import mogrify montage stream"
53
54 ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im6"
55 ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im6"
56 ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im6"
57 ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im6"
58 ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im6"
59 ALTERNATIVE_TARGET[display] = "${bindir}/display.im6"
60 ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im6"
61 ALTERNATIVE_TARGET[import] = "${bindir}/import.im6"
62 ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im6"
63 ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im6"
64 ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im6"
65
66 ALTERNATIVE_${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \
67     convert.1 display.1 identify.1 import.1 mogrify.1 montage.1 stream.1"
68
69 ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1"
70 ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im6.1"
71 ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1"
72 ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im6.1"
73 ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1"
74 ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im6.1"
75 ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1"
76 ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im6.1"
77 ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1"
78 ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im6.1"
79 ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1"
80 ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im6.1"
81 ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1"
82 ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im6.1"
83 ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1"
84 ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im6.1"
85 ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1"
86 ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im6.1"
87 ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1"
88 ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im6.1"
89 ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1"
90 ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im6.1"