43aeb6272c697f972025c4e855b28da538cd8f42
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-kernel / linux / linux-renesas_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 require recipes-kernel/linux/linux-agl.inc
4
5 SRC_URI_append  = " file://namespace_fix.cfg \
6     "
7
8 # This can fix a compilation issue with perf. As this seems to collide with the cogent layer
9 # we apply this here by variable and reset it when the -adas layer is present.
10 perfFIX ??= " file://9999-perf-libbft-upstream.patch "
11 #
12
13 # Add ADSP patch to enable and add sound hardware abstraction
14 SRC_URI_append_ulcb = " \
15     file://0004-ADSP-enable-and-add-sound-hardware-abstraction.patch \
16     ${perfFIX} \
17 "
18
19 # For Xen
20 SRC_URI_append = " \
21     ${@bb.utils.contains('AGL_XEN_WANTED','1','file://xen-be.cfg','',d)} \
22 "
23 SRC_URI_append_m3ulcb = " \
24     ${@bb.utils.contains('AGL_XEN_WANTED','1','file://r8a7796-m3ulcb-xen.dts;subdir=git/arch/${ARCH}/boot/dts/renesas','',d)} \
25 "
26 KERNEL_DEVICETREE_append_m3ulcb = " \
27     ${@bb.utils.contains('AGL_XEN_WANTED','1','renesas/r8a7796-m3ulcb-xen.dtb','',d)} \
28 "