Merge "[rcar-gen3] update weston recipes bbappend"
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-graphics / wayland / weston_%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://weston-rcar.ini \
5     "
6
7 do_install_append() {
8     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
9     install -d ${D}${WESTON_INI_CONFIG}
10     install -m 0644 ${WORKDIR}/weston-rcar.ini ${D}${WESTON_INI_CONFIG}/weston.ini
11 }
12
13 FILES_${PN}_append_rcar-gen3 = " \
14     ${libexecdir}/weston-screenshooter \
15     ${libexecdir}/weston-ivi-shell-user-interface \
16     ${libexecdir}/weston-keyboard \
17     ${libexecdir}/weston-simple-im \
18     ${libexecdir}/weston-desktop-shell \
19 "
20
21 FILES_${PN}_append = " \
22     ${sysconfdir}/xdg/weston/weston.ini \
23     "