4ee0c8873b087070153a7d439e4b94f4424ac16a
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-connectivity / linuxptp / linuxptp_1.4.bb
1 DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for Linux"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5 SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \
6            file://build-Allow-CC-and-prefix-to-be-overriden.patch"
7
8 SRC_URI[md5sum] = "a37ad2b2ef7d1ebc4d64a66d3fe55cdf"
9 SRC_URI[sha256sum] = "6cfd5291fb7394cc9f25458927874a203971b66b76d1c9d6568e007d0cbd81f2"
10
11 EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \
12                 EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC ${CFLAGS}'"
13
14 do_install () {
15     install -d ${D}/${bindir}
16     install -p ${S}/ptp4l  ${D}/${bindir}
17     install -p ${S}/pmc  ${D}/${bindir}
18     install -p ${S}/phc2sys  ${D}/${bindir}
19     install -p ${S}/hwstamp_ctl  ${D}/${bindir}
20 }