Upgrade wayland-ivi-extension
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-backport / gstreamer_bp_krogoth / gstreamer1.0-meta-base.bb
1 SUMMARY = "Gstreamer1.0 package groups"
2 LICENSE = "MIT"
3
4 # Due to use of COMBINED_FEATURES
5 PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7 inherit packagegroup
8
9 COMMERCIAL_PLUGINS = "${COMMERCIAL_AUDIO_PLUGINS} ${COMMERCIAL_VIDEO_PLUGINS}"
10 DEPENDS_UGLY="${@'gstreamer1.0-plugins-ugly' if 'ugly' in COMMERCIAL_PLUGINS.split('-') else ''}"
11 DEPENDS_BAD="${@'gstreamer1.0-plugins-bad' if 'bad' in COMMERCIAL_PLUGINS.split('-') else ''}"
12 DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good ${DEPENDS_UGLY} ${DEPENDS_BAD}"
13
14 PACKAGES = "\
15     gstreamer1.0-meta-base \
16     gstreamer1.0-meta-x11-base \
17     gstreamer1.0-meta-audio \
18     gstreamer1.0-meta-debug \
19     gstreamer1.0-meta-video"
20
21 ALLOW_EMPTY_gstreamer1.0-meta-base = "1"
22 ALLOW_EMPTY_gstreamer1.0-meta-x11-base = "1"
23 ALLOW_EMPTY_gstreamer1.0-meta-audio = "1"
24 ALLOW_EMPTY_gstreamer1.0-meta-debug = "1"
25 ALLOW_EMPTY_gstreamer1.0-meta-video = "1"
26
27 RDEPENDS_gstreamer1.0-meta-base = "\
28     ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gstreamer1.0-meta-x11-base', '', d)} \
29     gstreamer1.0 \
30     gstreamer1.0-plugins-base-playback \
31     gstreamer1.0-plugins-base-gio \
32     ${@bb.utils.contains('COMBINED_FEATURES', 'alsa', 'gstreamer1.0-plugins-base-alsa', '',d)} \
33     gstreamer1.0-plugins-base-volume \
34     gstreamer1.0-plugins-base-audioconvert \
35     gstreamer1.0-plugins-base-audioresample \
36     gstreamer1.0-plugins-base-typefindfunctions \
37     gstreamer1.0-plugins-base-videoscale \
38     gstreamer1.0-plugins-base-videoconvert \
39     gstreamer1.0-plugins-good-autodetect \
40     gstreamer1.0-plugins-good-souphttpsrc"
41
42 RRECOMMENDS_gstreamer1.0-meta-x11-base = "\
43     gstreamer1.0-plugins-base-ximagesink \
44     gstreamer1.0-plugins-base-xvimagesink"
45
46 RDEPENDS_gstreamer1.0-meta-audio = "\
47     gstreamer1.0-meta-base \
48     gstreamer1.0-plugins-base-vorbis \
49     gstreamer1.0-plugins-base-ogg \
50     gstreamer1.0-plugins-good-wavparse \
51     gstreamer1.0-plugins-good-flac \
52     ${COMMERCIAL_AUDIO_PLUGINS}"
53
54 RDEPENDS_gstreamer1.0-meta-debug = "\
55     gstreamer1.0-meta-base \
56     gstreamer1.0-plugins-good-debug \
57     gstreamer1.0-plugins-base-audiotestsrc \
58     gstreamer1.0-plugins-base-videotestsrc"
59
60 RDEPENDS_gstreamer1.0-meta-video = "\
61     gstreamer1.0-meta-base \
62     gstreamer1.0-plugins-good-avi \
63     gstreamer1.0-plugins-good-matroska \
64     gstreamer1.0-plugins-base-theora \
65     ${COMMERCIAL_VIDEO_PLUGINS}"
66
67 RRECOMMENDS_gstreamer1.0-meta-video = "\
68     gstreamer1.0-meta-audio"