ffbf791e8dc1557ee08784550a86032e7324640a
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
3 require recipes-kernel/linux/linux-agl.inc
4 require recipes-kernel/linux/linux-agl-4.14.inc
5
6 # ENABLE DSI
7 # ported from https://github.com/k-quigley/linux
8 SRC_URI_append = " \
9     file://dsi/0001-Add-devicetree-support-for-RaspberryPi-7-panel-over-.patch \
10     file://dsi/0002-drm-vc4-Make-DSI-call-into-the-bridge-after-the-DSI-.patch \
11     file://dsi/0003-drm-vc4-Set-up-the-DSI-host-at-pdev-probe-time-not-c.patch \
12     file://dsi/0004-drm-panel-Backport-4.15-support-for-the-Raspberry-Pi.patch \
13 "
14
15 # NOTE: Kprobes need to be disabled until linux-raspberrypi gets updated
16 #       to newer than 4.14.104 to avoid lttng-modules failing to build.
17 SRC_URI_append = "\
18     ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
19     file://disable_kprobes.cfg \
20 "
21
22 CMDLINE_DEBUG = ""
23 CMDLINE_append = " usbhid.mousepoll=0"
24
25 # Add options to allow CMA to operate
26 CMDLINE_append = ' ${@oe.utils.conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
27
28 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
29 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
30
31 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
32 PACKAGES += "kernel-module-snd-bcm2835"
33
34 # Enable support for usb video class for usb camera devices
35 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
36
37 # Enable support for joystick devices
38 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
39
40 # Enable support for Pi foundation touchscreen
41 SRC_URI_append = " file://raspberrypi-panel.cfg"
42 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
43
44 # Enable bt hci uart
45 SRC_URI_append = " file://raspberrypi-hciuart.cfg"
46 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
47
48 # ENABLE NETWORK (built-in)
49 SRC_URI_append = " file://raspberrypi_network.cfg"
50 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi_network.cfg"