meta-agl-bsp: meta-raspberrypi: handle zeus upgrade
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
3 require recipes-kernel/linux/linux-agl.inc
4
5 SRC_URI_append = "\
6     ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
7 "
8
9 CMDLINE_DEBUG = ""
10 CMDLINE_append = " usbhid.mousepoll=0"
11
12 # Add options to allow CMA to operate
13 CMDLINE_append = ' ${@oe.utils.conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
14
15 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
16 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
17
18 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
19 PACKAGES += "kernel-module-snd-bcm2835"
20
21 # Enable support for usb video class for usb camera devices
22 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
23
24 # Enable support for joystick devices
25 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
26
27 # Enable support for Pi foundation touchscreen
28 SRC_URI_append = " file://raspberrypi-panel.cfg"
29 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
30
31 # Enable bt hci uart
32 SRC_URI_append = " file://raspberrypi-hciuart.cfg"
33 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
34
35 # ENABLE NETWORK (built-in)
36 SRC_URI_append = " file://raspberrypi_network.cfg"
37 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi_network.cfg"