f78e0b5eb32de93c766133d62ae07ce6e16231e0
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
3 require recipes-kernel/linux/linux-agl.inc
4
5 SRC_URI_append = "\
6     ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
7 "
8 #take in account that linux under xen should use the hvc0 console
9 SERIAL_OPTION = "${@bb.utils.contains('AGL_XEN_WANTED','1','hvc0','115200;ttyS0',d)}"
10 SERIAL = "${@oe.utils.conditional("ENABLE_UART", "1", "console=${SERIAL_OPTION}", "", d)}"
11
12 CMDLINE_DEBUG = ""
13
14 #XEN related option
15 CMDLINE_append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','clk_ignore_unused','',d)}'
16
17 #workaround for crash during brcmfmac loading. Disable it at this moment
18 CMDLINE_append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','modprobe.blacklist=brcmfmac','',d)}'
19
20 CMDLINE_append = " usbhid.mousepoll=0"
21
22 # Add options to allow CMA to operate
23 CMDLINE_append = ' ${@oe.utils.conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
24
25 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
26 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
27
28 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
29 PACKAGES += "kernel-module-snd-bcm2835"
30
31 # Enable support for usb video class for usb camera devices
32 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
33
34 # Enable support for joystick devices
35 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
36
37 # Enable support for Pi foundation touchscreen
38 SRC_URI_append = " file://raspberrypi-panel.cfg"
39 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
40
41 # Enable bt hci uart
42 SRC_URI_append = " file://raspberrypi-hciuart.cfg"
43 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
44
45 # ENABLE NETWORK (built-in)
46 SRC_URI_append = " file://raspberrypi_network.cfg"
47 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi_network.cfg"