Fix bitbake -c menuconfig for linux-raspberrypi
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
3 require recipes-kernel/linux/linux-agl.inc
4
5 SRC_URI_append = "\
6     ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
7     file://0001-mconf-menuconfig.patch \
8 "
9 #take in account that linux under xen should use the hvc0 console
10 SERIAL_OPTION = "${@bb.utils.contains('AGL_XEN_WANTED','1','hvc0','115200;ttyS0',d)}"
11 SERIAL = "${@oe.utils.conditional("ENABLE_UART", "1", "console=${SERIAL_OPTION}", "", d)}"
12
13 CMDLINE_DEBUG = ""
14
15 #XEN related option
16 CMDLINE_append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','clk_ignore_unused','',d)}'
17
18 #workaround for crash during brcmfmac loading. Disable it at this moment
19 CMDLINE_append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','modprobe.blacklist=brcmfmac','',d)}'
20
21 CMDLINE_append = " usbhid.mousepoll=0"
22
23 # Add options to allow CMA to operate
24 CMDLINE_append = '${@oe.utils.conditional("ENABLE_CMA", "1", " coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
25
26 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
27 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
28
29 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
30 PACKAGES += "kernel-module-snd-bcm2835"
31
32 # Enable support for usb video class for usb camera devices
33 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
34
35 # Enable support for joystick devices
36 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
37
38 # Enable support for Pi foundation touchscreen
39 SRC_URI_append = " file://raspberrypi-panel.cfg"
40 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
41
42 # Enable bt hci uart
43 SRC_URI_append = " file://raspberrypi-hciuart.cfg"
44 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
45
46 # ENABLE NETWORK (built-in)
47 SRC_URI_append = " file://raspberrypi_network.cfg"
48 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi_network.cfg"