d9f843e9cfa9709740efaa40c043db0aa4830618
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
3 require recipes-kernel/linux/linux-agl.inc
4 require recipes-kernel/linux/linux-agl-4.9.inc
5
6 SRC_URI_append = "\
7     ${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
8 "
9
10 CMDLINE_DEBUG = ""
11 CMDLINE_append = " usbhid.mousepoll=0"
12
13 # Add options to allow CMA to operate
14 CMDLINE_append = ' ${@base_conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
15
16 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
17 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
18
19 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
20 PACKAGES += "kernel-module-snd-bcm2835"
21
22 # Enable support for usb video class for usb camera devices
23 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
24
25 # Enable support for joystick devices
26 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
27
28 # Enable support for Pi foundation touchscreen
29 SRC_URI_append = " file://raspberrypi-panel.cfg"
30 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"