linux-raspberrypi: Add 4.19 for Raspberry Pi 4
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
3 require recipes-kernel/linux/linux-agl.inc
4
5 # NOTE: Kprobes need to be disabled until linux-raspberrypi gets updated
6 #       to newer than 4.14.104 to avoid lttng-modules failing to build.
7 SRC_URI_append = "\
8     ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
9     file://disable_kprobes.cfg \
10 "
11
12 CMDLINE_DEBUG = ""
13 CMDLINE_append = " usbhid.mousepoll=0"
14
15 # Add options to allow CMA to operate
16 CMDLINE_append = ' ${@oe.utils.conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
17
18 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
19 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
20
21 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
22 PACKAGES += "kernel-module-snd-bcm2835"
23
24 # Enable support for usb video class for usb camera devices
25 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
26
27 # Enable support for joystick devices
28 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
29
30 # Enable support for Pi foundation touchscreen
31 SRC_URI_append = " file://raspberrypi-panel.cfg"
32 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
33
34 # Enable bt hci uart
35 SRC_URI_append = " file://raspberrypi-hciuart.cfg"
36 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
37
38 # ENABLE NETWORK (built-in)
39 SRC_URI_append = " file://raspberrypi_network.cfg"
40 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi_network.cfg"