Revert "Fix rpi touchscreen support on master"
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2
3 require recipes-kernel/linux/linux-agl.inc
4 require recipes-kernel/linux/linux-agl-4.14.inc
5
6 # NOTE: Kprobes need to be disabled until linux-raspberrypi gets updated
7 #       to newer than 4.14.104 to avoid lttng-modules failing to build.
8 SRC_URI_append = "\
9     ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
10     file://disable_kprobes.cfg \
11 "
12
13 CMDLINE_DEBUG = ""
14 CMDLINE_append = " usbhid.mousepoll=0"
15
16 # Add options to allow CMA to operate
17 CMDLINE_append = ' ${@oe.utils.conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
18
19 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
20 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
21
22 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
23 PACKAGES += "kernel-module-snd-bcm2835"
24
25 # Enable support for usb video class for usb camera devices
26 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
27
28 # Enable support for joystick devices
29 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
30
31 # Enable support for Pi foundation touchscreen
32 SRC_URI_append = " file://raspberrypi-panel.cfg"
33 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
34
35 # Enable bt hci uart
36 SRC_URI_append = " file://raspberrypi-hciuart.cfg"
37 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
38
39 # ENABLE NETWORK (built-in)
40 SRC_URI_append = " file://raspberrypi_network.cfg"
41 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi_network.cfg"