weston: Set XDG_RUNTIME_DIR for Raspberry Pi
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-graphics / wayland / weston_%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://weston-raspberrypi.ini \
5     file://weston.sh \
6     "
7
8 do_install_append() {
9     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
10     install -d ${D}${WESTON_INI_CONFIG}
11     install -m 0644 ${WORKDIR}/weston-raspberrypi.ini ${D}${WESTON_INI_CONFIG}/weston.ini
12
13     install -d ${D}/${sysconfdir}/profile.d
14     install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
15 }
16
17 FILES_${PN} += " \
18     ${sysconfdir}/xdg/weston/weston.ini \
19     ${sysconfdir}/profile.d/weston.sh \
20     "