mesa: Upgrade Mesa for Raspberry Pi 4
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-graphics / mesa / mesa_19.1.6.bb
1 require ${BPN}.inc
2
3 SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4            file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
5            file://0002-meson.build-make-TLS-GLX-optional-again.patch \
6            file://0003-Allow-enable-DRI-without-DRI-drivers.patch \
7            "
8
9 SRC_URI[md5sum] = "7dbb40b8d10e89bee0a5bfc85350647b"
10 SRC_URI[sha256sum] = "2a369b7b48545c6486e7e44913ad022daca097c8bd937bf30dcf3f17a94d3496"
11
12 UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
13
14 #because we cannot rely on the fact that all apps will use pkgconfig,
15 #make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
16 do_install_append() {
17     if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
18         sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
19     fi
20 }