Forward port local-arm-futex patch to poky morty HEAD
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-graphics / mesa / mesa_12.0.3.bb
1 require ${BPN}.inc
2
3 SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz \
4            file://replace_glibc_check_with_linux.patch \
5            file://disable-asm-on-non-gcc.patch \
6 "
7
8 SRC_URI[md5sum] = "1113699c714042d8c4df4766be8c57d8"
9 SRC_URI[sha256sum] = "1dc86dd9b51272eee1fad3df65e18cda2e556ef1bc0b6e07cd750b9757f493b1"
10
11 #because we cannot rely on the fact that all apps will use pkgconfig,
12 #make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
13 do_install_append() {
14     if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
15         sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
16     fi
17 }