mesa: Upgrade Mesa for Raspberry Pi 4
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-graphics / mesa / libglu_9.0.1.bb
1 SUMMARY = "The OpenGL utility toolkit"
2 DESCRIPTION = "GLU is a utility toolkit used with OpenGL implementations"
3
4 HOMEPAGE = "http://mesa3d.org"
5 BUGTRACKER = "https://bugs.freedesktop.org"
6 SECTION = "x11"
7 LICENSE = "MIT"
8 LIC_FILES_CHKSUM = "file://include/GL/glu.h;endline=29;md5=6b79c570f644363b356456e7d44471d9 \
9                     file://src/libtess/tess.c;endline=29;md5=6b79c570f644363b356456e7d44471d9"
10
11 # Epoch as this used to be part of mesa
12 PE = "2"
13 PR = "0"
14
15 SRC_URI = "https://mesa.freedesktop.org/archive/glu/glu-${PV}.tar.gz"
16
17 SRC_URI[md5sum] = "5599a0e0a97335e10239d9165aced60d"
18 SRC_URI[sha256sum] = "f6f484cfcd51e489afe88031afdea1e173aa652697e4c19ddbcb8260579a10f7"
19
20 S = "${WORKDIR}/glu-${PV}"
21
22 DEPENDS = "virtual/libgl"
23
24 inherit autotools pkgconfig distro_features_check
25
26 # Requires libGL.so which is provided by mesa when x11 in DISTRO_FEATURES
27 REQUIRED_DISTRO_FEATURES = "x11 opengl"
28
29 # Remove the mesa-glu dependency in mesa-glu-dev, as mesa-glu is empty
30 RDEPENDS_${PN}-dev = ""