Convert to new override syntax
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-bsp / rpi-u-boot-scr / rpi-u-boot-scr.bbappend
1 FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2
3 SRC_URI:append =" \
4     ${@bb.utils.contains('AGL_XEN_WANTED','1',' file://boot_xen.cmd','',d)} \
5 "
6
7 do_compile:append() {
8
9  # if xen feature is activated we overwirte the boot script with xen specific one
10    if [ "${AGL_XEN_WANTED}" = "1" ]; then
11         sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
12             -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
13             -e 's/@@MACHINE@@/${MACHINE}/' \
14               "${WORKDIR}/boot_xen.cmd" > "${WORKDIR}/boot.cmd"
15
16         mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
17    fi
18 }